注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

谈笑涧

已开通独立前端博客,请访问 http://www.candoudou.com

 
 
 

日志

 
 

解决wordpress升级最新3.5报Missing argument 2 for wpdb::prepare()  

2013-01-15 11:18:58|  分类: 互联网 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

今天看了一下我的博客,提示wordpress更新到3.5,于是让它自动升级到wordpress3.5,谁知道升级之后出现了下面的提示信息错误:


Warning: Missing argument 2 for wpdb::prepare(), called in /home/candoudo/public_html/wordpress/wp-content/themes/inove/footer.php on line 21 and defined in/home/candoudo/public_html/wordpress/wp-includes/wp-db.php on line 990


解决方法:

这要看你的页脚源代码,引用了哪个函数。估计是使用prepare()获取数据产生了不安全因素。致使报错。这一般是由于3.5在安全方面加强导致的。
方法:
找到$wpdb->prepare('x')在后面添加一个空内容$wpdb->prepare('x',''),中x是表示原有内容。

  评论这张
 
阅读(301)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017